Yum fails with; Repository 'interworx-7-release' is missing name in configuration

Interworx v7.0.9 I am getting error when doing yum update:

Loaded plugins: fastestmirror
Repository ‘interworx-7-release’ is missing name in configuration, using id
Repository ‘interworx-7-release-candidate’ is missing name in configuration, using id
Loading mirror speeds from cached hostfile
epel/x86_64/metalink | 17 kB 00:00:00

One of the configured repositories failed (Unknown),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

Wen going to Server, Software updates both these repositories are enabled but empty when I try to edit.

/etc/yum.repos.d/
total 128
drwxr-xr-x. 2 root root 4096 Aug 22 15:38 .
drwxr-xr-x. 106 root root 8192 Sep 2 13:15 …
-rw-r–r--. 1 root root 1664 Apr 7 23:01 CentOS-Base.repo
-rw-r–r--. 1 root root 1309 Apr 7 23:01 CentOS-CR.repo
-rw-r–r--. 1 root root 649 Apr 7 23:01 CentOS-Debuginfo.repo
-rw-r–r--. 1 root root 314 Apr 7 23:01 CentOS-fasttrack.repo
-rw-r–r--. 1 root root 630 Apr 7 23:01 CentOS-Media.repo
-rw-r–r--. 1 root root 1331 Apr 7 23:01 CentOS-Sources.repo
-rw-r–r--. 1 root root 7577 Apr 7 23:01 CentOS-Vault.repo
-rw-r–r--. 1 root root 616 Apr 7 23:01 CentOS-x86_64-kernel.repo
-rw-r–r--. 1 root root 1050 Sep 18 2019 epel.repo
-rw-r–r--. 1 root root 1149 Sep 18 2019 epel-testing.repo
-rw-r–r--. 1 root root 3335 Sep 13 07:43 interworx-7.repo
-rw-r–r--. 1 root root 142 Aug 22 14:39 interworx-hotfix.repo
-rw-r–r--. 1 root root 172 Aug 22 14:18 MariaDB.repo
-rw-r–r--. 1 root root 446 Aug 17 11:29 remi-glpi91.repo
-rw-r–r--. 1 root root 446 Aug 17 11:29 remi-glpi92.repo
-rw-r–r--. 1 root root 446 Aug 17 11:29 remi-glpi93.repo
-rw-r–r--. 1 root root 446 Aug 17 11:29 remi-glpi94.repo
-rw-r–r--. 1 root root 855 Aug 17 11:29 remi-modular.repo
-rw-r–r--. 1 root root 456 Aug 17 11:29 remi-php54.repo
-rw-r–r--. 1 root root 1314 Aug 17 11:29 remi-php70.repo
-rw-r–r--. 1 root root 1314 Aug 17 11:29 remi-php71.repo
-rw-r–r--. 1 root root 1314 Aug 17 11:29 remi-php72.repo
-rw-r–r--. 1 root root 1314 Aug 22 14:18 remi-php73.repo
-rw-r–r--. 1 root root 1314 Aug 17 11:29 remi-php74.repo
-rw-r–r--. 1 root root 1314 Aug 17 11:29 remi-php80.repo
-rw-r–r--. 1 root root 2604 Sep 13 12:03 remi.repo
-rw-r–r--. 1 root root 750 Aug 17 11:29 remi-safe.repo

Any help much appreciated.
Nico

Hi Nico

I have emailed you the file interworx.repo

I have seen similar with Centos 7 but not with Interworx and there were no real answers as to why Centos 7 fails yum or how to correctly fix it. It seemed trial and error and never sure if it was fixed due to changes or something higher up outside their control

I hope that helps a little but if it still fails, please open a support ticket with IW

Many thanks

John

Hi John,
Many thanks, it did not help, so I run the install script again and ctrl-c it after the yum bits where done.
It did the trick, not sure if you can run the whole script like in cPanel to fix any issues like such.

Kind regards,
Nico

STATUS: Looks like jailing is already setup
STATUS: Checking for YUM
STATUS: Updating yum (if needed)
STATUS: Installing yum-utils
STATUS: Installing InterWorx YUM repository

yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • base: mirror.cov.ukservers.com
  • epel: mirrors.ukfast.co.uk
  • extras: mirror.freethought-internet.co.uk
  • remi-php55: mirror.netweaver.uk
  • remi-php56: mirror.netweaver.uk
  • remi-php73: mirror.netweaver.uk
  • remi-safe: mirror.netweaver.uk
  • updates: mirror.freethought-internet.co.uk
    Resolving Dependencies
    –> Running transaction check
    —> Package interworx.noarch 0:7.0.9-1786.iworx will be updated
    —> Package interworx.noarch 0:7.0.10-1789.iworx will be an update
    —> Package interworx-horde.noarch 0:5.2.17-1786.iworx will be updated
    —> Package interworx-horde.noarch 0:5.2.17-1789.iworx will be an update
    —> Package interworx-phpmyadmin.noarch 0:4.9.5-1786.iworx will be updated
    —> Package interworx-phpmyadmin.noarch 0:4.9.5-1789.iworx will be an update
    —> Package interworx-roundcube.noarch 0:1.3.6-1786.iworx will be updated
    —> Package interworx-roundcube.noarch 0:1.3.6-1789.iworx will be an update
    —> Package interworx-smarty.noarch 0:2.6.19-1786.iworx will be updated
    —> Package interworx-smarty.noarch 0:2.6.19-1789.iworx will be an update
    –> Finished Dependency Resolution

Dependencies Resolved

OK, seems a bug as soon you go in Server, *
InterWorx Update Channel and change it to Release default,
it bugs the yum again, and error is back.

Check out /etc/yum.repos.d/interworx-7.repo. Toward the bottom of that file, there is probably a repo definition that only contains enabled=1. Remove this and yum update should be fine again. I will post the exact contents of the half-defined repo once I’m in front of a computer again. We have a bug report in already about this, so we are working on it.

Thanks @iworx-brandon,

This part :slight_smile:

[interworx-7-beta]
name=InterWorx Beta - RedHat Enterprise $releasever
baseurl=http://updates.interworx.com/interworx/7/beta/RPMS/$releasever/$basearch
priority=1
gpgcheck=1
enabled=0
[interworx-7-release]
enabled=1

Ok, yum updated, but also the phpmyadmin bug is in this 7 version.

Running transaction
Updating : interworx-7.0.10-1789.iworx.noarch 1/10
/home/interworx/bin
Updating : interworx-phpmyadmin-4.9.5-1789.iworx.noarch 2/10
Updating : interworx-smarty-2.6.19-1789.iworx.noarch 3/10
Updating : interworx-roundcube-1.3.6-1789.iworx.noarch 4/10
Updating : interworx-horde-5.2.17-1789.iworx.noarch 5/10
warning: %post(interworx-horde-5.2.17-1789.iworx.noarch) scriptlet failed, exit status 102
Non-fatal POSTIN scriptlet failure in rpm package interworx-horde-5.2.17-1789.iworx.noarch
Cleanup : interworx-horde-5.2.17-1786.iworx.noarch 6/10
Cleanup : interworx-roundcube-1.3.6-1786.iworx.noarch 7/10
Cleanup : interworx-smarty-2.6.19-1786.iworx.noarch 8/10
/var/tmp/rpm-tmp.k0ijsz: line 8: -n: command not found
error: %preun(interworx-phpmyadmin-4.9.5-1786.iworx.noarch) scriptlet failed, exit status 127
Error in PREUN scriptlet in rpm package interworx-phpmyadmin-4.9.5-1786.iworx.noarch
error: interworx-phpmyadmin-4.9.5-1786.iworx.noarch: erase failed
Cleanup : interworx-7.0.9-1786.iworx.noarch 9/10
Gracefully restarting iworx-web: [ OK ]
Verifying : interworx-phpmyadmin-4.9.5-1789.iworx.noarch 1/10
Verifying : interworx-roundcube-1.3.6-1789.iworx.noarch 2/10
Verifying : interworx-horde-5.2.17-1789.iworx.noarch 3/10
Verifying : interworx-smarty-2.6.19-1789.iworx.noarch 4/10
Verifying : interworx-7.0.10-1789.iworx.noarch 5/10
Verifying : interworx-phpmyadmin-4.9.5-1786.iworx.noarch 6/10
Verifying : interworx-horde-5.2.17-1786.iworx.noarch 7/10
Verifying : interworx-smarty-2.6.19-1786.iworx.noarch 8/10
Verifying : interworx-roundcube-1.3.6-1786.iworx.noarch 9/10
Verifying : interworx-7.0.9-1786.iworx.noarch 10/10

Updated:
interworx.noarch 0:7.0.10-1789.iworx interworx-horde.noarch 0:5.2.17-1789.iworx interworx-phpmyadmin.noarch 0:4.9.5-1789.iworx
interworx-roundcube.noarch 0:1.3.6-1789.iworx interworx-smarty.noarch 0:2.6.19-1789.iworx

Failed:
interworx-phpmyadmin.noarch 0:4.9.5-1786.iworx

rpm -q interworx-phpmyadmin
interworx-phpmyadmin-4.9.5-1786.iworx.noarch
interworx-phpmyadmin-4.9.5-1789.iworx.noarch

fixed with:

rpm -e interworx-phpmyadmin-4.9.5-1786.iworx.noarch --noscripts
[[email protected] ~]# rpm -q interworx-phpmyadmin
interworx-phpmyadmin-4.9.5-1789.iworx.noarch

Just to let you know.

Yeah, removing those last two lines:

[interworx-7-release]
enabled=1

Should let you move forward.

The first fively cron that runs after the upgrade should remove duplicate versions of phpmyadmin.

OK thanks for letting me know :slight_smile: