Yum/update problems

Hoping someone can help me out with a couple problems I’m having.

First issue: I haven’t seen any updates appear in the Nodeworx control panel since November '07 (and this was a single Perl module.)

Second issue: When I tried to run ‘yum update’ from the command line it gives me dependency errors as shown below:

$ sudo yum update interworx
Setting up Update Process
Resolving Dependencies
–> Running transaction check
—> Package interworx.noarch 0:3.0.4-100.iworx set to be updated
–> Processing Dependency: interworx = 3.0.3-1017.iworx for package: interworx-siteworx
–> Finished Dependency Resolution
Error: Missing Dependency: interworx = 3.0.3-1017.iworx is needed by package interworx-siteworx

$ yum list interworx interworx-siteworx interworx-nodeworx
Installed Packages
interworx.noarch 3.0.3-1017.iworx installed
interworx-nodeworx.noarch 3.0.3-1017.iworx installed
interworx-siteworx.noarch 3.0.3-1017.iworx installed
Available Packages
interworx.noarch 3.0.4-100.iworx interworx-cp-noa


Hi Rob,

Sounds like the rpm meta data may be confused or something on your server. If you open a support ticket we’ll take a look for you and get things fixed up.


I submitted a ticket, then figured out that I needed to use ‘upgrade’ instead of ‘update’ for the interworx packages. Everything went through, although I’ll keep an eye on the Software Updates control panel to see if that still doesn’t work.