Bulk TTL Update

Is there a simple way to update the TTL for all Zones on a server at once?

Hi Staxed
Good question
I’m sorry, you did not state if you are looking to change unique TTL values for a specific TTL change (ie. just A record or all TTL values, ie MX, A etc…)
You can easily change all TTL values by the following:
Log into Nodeworx, services, MySQl, phpmyadmin
Select Iworx for database
select query
run this query, but change values to match your current TTL value and required TTL value
UPDATE dns_records
SET ttl = replace(ttl, ‘43200’, ‘600’)
eg
UPDATE dns_records
SET ttl = replace(ttl, ‘<Current TTL Value>’, ‘<Required TTL Value>’)
execute query, and it will conform the number of changes made.
Close phpmyadmin and logout of nodeworx
Please remember, as it is DNS and specific to TTL, you will have to wait for the TTL original value to expire, for the new value to be used (whee the domain DNS has already been cached), or clear your stale cache on computer, and hope your not using a DNS higher up on your broadband connection, if you are, change NS used on computer to try to see if you can test sooner for TTL changes
I hope that helps.
Lastly, I accept no responsibility for anything if this fails or does not give required required result, so use at your own risk, and please do not make randon changes to Iworx DB, you could break it
Many thanks
John

That was a lot of explanation for a simple question, lol, thanks.

I’ll modify the query a bit though, as I don’t have a “current ttl” to use, as there are quite a few different ones. Trying to get them all line up to the same value in all instances. Thanks for the headstart!

just got around to giving this a shot and I don’t see the option to select the iworx database within phpmyadmin?

Hi Staxed
I think a picture paints a thousand words
Please see pics, and you select iworx DB, then iworx
Hope that helps
Many thanks
John

I don’t have the option to select the Interworx DB, only localhost…interesting, lol

Hi staxed

Oh dear

You need to login to nodeworx as the primary admin account

If you still do not see the IW db, then if you know the root MySQL password, you should be able to run the query from command line

Many thanks

John

I am logged in as the primary (the only actually) admin account. That has me worried now though if I’m supposed to be able to see it and can’t…

Hi staxed

It is not shown, you have to click localhost and it is a drop down option

Are you on centos 7, if so, I would need to check as we use centos 6

Many thanks

John

I know it’s a drop down, I’m not THAT slow (but pretty close I feel, lol). I only have the local host option, and yup, on Centos7.

Hi Staxed
Sorry, I did not mean to say you were slow sorry.
I tested on a default centos7 minimal install, with latest IW installed, and it appears the same as centos6
I think there must be something different on your server if you cannot see it
Many thanks
John

server-version.png

centos7-IW-CP.png

centos7-IW-CP.png

centos7-IW-CP.png

I dont know how to show IW DB

I’ve check with command line, there is no iworx DB.

Hi Khairil Gunawan
Please could I ask:
What distro and IW-CP you are using
What licence type you have, 1 domain, 35 domain or unlimted
What Mysql are you using
I have checked on our 1 domain (used only for DNS) and it is shown, so this is strange, as it is not limted to any domain licence limits.
I am not sure if Stax resolved his issue, bit if needed quickly, you may want to open a support ticket with your license provider
Many thanks
John

I direct buy license on interworx.com
Owned license

my server information.

Screenshot_356.png

Hi khairil

Many thank

I have thought about this all today, and all our servers show Iw db, so I cannot reproduce sorry

The only thing I can think off (as clearly Iw is working as is myphpadmin), is if you reset the MySQL password from nodeworx, services, log out and clear browser history, login and see if it is shown

If not, as this is the second time it has been raised, I would open a support ticket with Iw and let Iw have a look to see what’s happening

I’m sorry I cannot be of more help, but appreciate an update as to how you got on

Many thanks

John

Thanks for your reply,

I have new server with different kernel and system installed 3 days ago,

But iworx db also not showing.

Maybe I need open support ticket now,

Thanks!

Screenshot_362.png

I was just reading this thread and I don’t have iworx db showing either, it did not show on my old server and also does not show on my present one.
running centos 6.8 and InterWorx-CP v5.1.41 [Unlimited Domain]
would be interested in the outcome of this issue and what was done to fix it.

Hi
I completely wiped and reloaded a test server today, Centos 7 with IW-CP 5.1.41 (no updates installed), and I was able to see the Iworx DB was missing from myphpadmin.
This was good news and bad, bad, it was not shown but good news was I reproduced issue.
Please could I ask if all of you had issues with myphpadmin from first install, i.e. myphpadmin errored on sessions
This is exactly what my new install showed - myphpadmin error on sessions, I corrected and when accessing myphpadmin, no Iworx DB shown - only localhost
If this is the case, and might be worth trying anyway, to resolve to show Iworx DB as follows:
SSH into server
(all as root)
check and make sure /usr/local/interworx/lib/phpMyAdmin3/sessions folder exists, if it does not, create it
check permissions on the following
/usr/local/interworx/var/session
drwx------. 2 iworx iworx 12288 Nov 12 21:06
/usr/local/interworx/lib/phpMyAdmin3/sessions
drwx–x--x 2 iworx-pma iworx-pma 4096 Nov 12 20:58
if both folders are present, with correct permissions, then proceed to clear all session files from the 2 folders
Sessions files to delete from the following folders
/usr/local/interworx/lib/phpMyAdmin3/sessions
/usr/local/interworx/var/session
Restart iworx
logout of SSH
close your browser and clear browser cache
login to nodeworx and confirm if Iworx DB now shown
Hopefully this resolves your issue but sorry if it does not, it has on my test server where I was able to reproduce the issue
Many thanks
John

Hi

yes I had the same sessions phpmyadmin error when first installed, in my case there was a missing sessions folder in phpMyAdmin3. added the folder and checked folder permissions. this cured the phpmyadmin error.

I have once again tried changing MySQL password and following your advice above but still no Iworx DB is shown, only localhost.
would be interested if anyone contacted support what the out come was and how the issue was fixed.
thank you for your time

Hi bear

Many thanks

Did you delete all session files from the 2 folders, restart iworx and clear your browser cache

When accessing phpmyadmin first time, do so from nodeworx, services, myphpadmin, which should set the new session and iworx db should be shown

Many thanks

John