Interworx Smarty update

Hi John, I’ll test disabling it later. Right now I am more worrying about last nights IW update, as all our interworx panels are down :frowning:

Some problem with Smarty afaict.

anybody else seing this?

Hi Michael

Hmm just tried logging into one of our live servers from mobile and it’s a white screen

I’ll have a look but think your correct over smarty upgrade

Many thanks


Hi Michael

Must not be my week, there’s an area power outage here. Alarms going off everywhere

Have you tried restarting iworx

I’ll email IW

Many thanks


This is from iworx.log

2017-05-25 11:19:13.81308 [nosess-y7ht-1hvl-WEB] [ERR] : Unknown ini access [iworx][dev_mode_js] : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.81819 [nosess-y7ht-1hvl-WEB] [INFO] : routing: Ctrl_Nodeworx_Index -> index : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.86969 [nosess-y7ht-1hvl-WEB] [INFO] : InterWorx_Smarty::_setUpSmartyTemplateDirsForTheme nsp : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.87007 [nosess-y7ht-1hvl-WEB] [INFO] : InterWorx_Smarty::_setUpSmartyTemplateDirsForTheme interworx : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90649 [nosess-y7ht-1hvl-WEB] [EMERG] : BEGIN STACKTRACE 1 - from logAnother in IWorx_Exception : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90670 [nosess-y7ht-1hvl-WEB] [EMERG] : Syntax error in template “file:/home/interworx/nodeworx/smarty/templates/nsp/index.tpl” on line 19 “{include file=header.tpl}” - Unexpected “.”, expected one of: “}” : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90688 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templateparser.php trigger_template_error (2727) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90701 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templateparser.php yy_syntax_error (2786) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90714 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/vendor/smarty/smarty/libs/sysplugins/smarty_internal_smartytemplatecompiler.php doParse (114) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90727 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php doCompile (404) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90740 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php compileTemplateSource (336) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90752 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/vendor/smarty/smarty/libs/sysplugins/smarty_template_compiled.php compileTemplate (204) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90767 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/vendor/smarty/smarty/libs/sysplugins/smarty_template_compiled.php compileTemplateSource (100) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90782 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/vendor/smarty/smarty/libs/sysplugins/smarty_template_compiled.php process (163) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90858 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/vendor/smarty/smarty/libs/sysplugins/smarty_internal_runtime_updatecache.php render (89) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90886 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/vendor/smarty/smarty/libs/sysplugins/smarty_template_cached.php updateCache (142) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90911 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/vendor/smarty/smarty/libs/sysplugins/smarty_internal_template.php render (201) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90934 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php render (216) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90958 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php _execute (122) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.90985 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/include/Smarty.i18n.php display (137) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91010 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/include/InterWorx.Smarty.php display (370) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91032 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/include/View/Smarty.php display (279) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91056 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/include/FrontController.php render (156) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91083 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/include/FrontController.php _route (96) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91113 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/html/index.php route (37) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91138 [nosess-y7ht-1hvl-WEB] [EMERG] : END STACKTRACE 1 - from logAnother in IWorx_Exception : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91563 [nosess-y7ht-1hvl-WEB] [EMERG] : ERROR: /usr/local/interworx/include/Env/Abstract.php(618): Uncaught IWorx_Exception_NotLoggedIn: Authentication Error (NodeWorx) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91592 [nosess-y7ht-1hvl-WEB] [EMERG] : : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91613 [nosess-y7ht-1hvl-WEB] [EMERG] : #0 /usr/local/interworx/include/Env/Abstract.php(603): Env_Abstract->_checkSession(‘NodeWorx’) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91646 [nosess-y7ht-1hvl-WEB] [EMERG] : #1 /usr/local/interworx/include/IW.php(274): Env_Abstract->getNodeWorxSession() : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91667 [nosess-y7ht-1hvl-WEB] [EMERG] : #2 /usr/local/interworx/include/View/Smarty/Nodeworx.php(45): IW::NW() : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91691 [nosess-y7ht-1hvl-WEB] [EMERG] : #3 /usr/local/interworx/include/Env/HTML.php(209): View_Smarty_Nodeworx->__construct(‘index’) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91720 [nosess-y7ht-1hvl-WEB] [EMERG] : #4 /usr/local/interworx/include/Ctrl/Abstract.php(65): Env_HTML->initView() : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91750 [nosess-y7ht-1hvl-WEB] [EMERG] : #5 /usr/local/interworx/include/Ctrl/Nodeworx/Abstract.php(45): Ctrl_Abstract->__construct() : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91765 [nosess-y7ht-1hvl-WEB] [EMERG] : #6 /usr/local/interworx/include/Ctrl/Nodeworx/Error.php(43): Ctrl_Nodeworx_Abstract->__construct() : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91779 [nosess-y7ht-1hvl-WEB] [EMERG] : #7 [internal function]: Ctrl_Nodeworx_Error->__construct() : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91790 [nosess-y7ht-1hvl-WEB] [EMERG] : #8 /usr/local/interworx/include/FrontController.php(345): ReflectionClass->newInstance() : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91801 [nosess-y7ht-1hvl-WEB] [EMERG] : #9 /usr/local/interworx/include/FrontController.php(147): FrontController->_invokeAction(‘Ctrl_Nodeworx_E…’, ‘unknownError’, ‘Syntax error in…’) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91812 [nosess-y7ht-1hvl-WEB] [EMERG] : #10 /usr/local/interworx/include/FrontController.php(252): FrontController->_route(‘Ctrl_Nodeworx_E…’, ‘unknownError’, ‘Syntax error in…’) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91828 [nosess-y7ht-1hvl-WEB] [EMERG] : #11 /usr/local/interworx/include/FrontController.php(123): FrontController->_handleUnknown(Object(SmartyCompilerException)) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91840 [nosess-y7ht-1hvl-WEB] [EMERG] : #12 /usr/local/interworx/html/index.php(37): FrontController->route(‘Ctrl_Nodeworx_I…’, ‘index’) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91855 [nosess-y7ht-1hvl-WEB] [EMERG] : #13 {main} : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91886 [nosess-y7ht-1hvl-WEB] [EMERG] : ----- DEBUG STACKTRACE BEGIN ----- : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91899 [nosess-y7ht-1hvl-WEB] [EMERG] : /usr/local/interworx/include/IWorxDebug.php getStackTrace (167) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3
2017-05-25 11:19:13.91912 [nosess-y7ht-1hvl-WEB] [EMERG] : 0 exceptionHandler (0) : /nodeworx/index?uri=L25vZGV3b3J4L292ZXJ2aWV3

John, do you know how to roll back an IW update? /usr/local/interworx/var/log/upgrade.log is empty, so I don’t see what has been updated.

Restart didn’t work. All sites work though, so only Nodeworx/Siteworx access not working.

Power outage? When it rains, it pours, right?

Hi Michael

Haha yes, air con stopped and if I go outside, alarms are deafening

I’ve emailed IW this thread

Many thanks


Hi Michael

Power just came back on - a paddy man digging cut through a live cable so may go off again

I have just checked our servers from pc, and access is fine - thinkimg it may have taken mobile a little time to drop wifi to 4g or the power outage had just happened at that moment

I would open a support ticket and let IW have a look, but from your logs, it looks as if an end code is missing (})

Many thanks


Hi Michael

Sorry, just catching up

Ssh into server as root or si

yum downgrade interworx-smarty

This should downgrade to and erased

Many thanks


Your servers are on stable channel, right? Mine have been on RC and yesterday evening 5.1.52-1311 was installed. could you check your version?

Oh, btw, I just remembered - it was chinese, I was simply asking you, if you don’t speak Chinese :smiley:

Downgrading Smarty didn’t help :frowning:

Hi Michael

Haha Chinese :frowning: thought you were swearing at me haha

Yes, production servers run stable, test servers run RC, but we updated this morning circa 7am and reverted update to stable, so we manually update production servers stops unwanted issues usually

The yum log you check is from logs, system logs, yum log or if you ssh into server, you could use yum history list all

The rollback worked fine on test server

Many thanks


Oh dear

Power just went off but just back on now

I’ll start a centos 7 and test on that

Have you opened a support ticket

Many thanks


Have not opened a ticket yet - they are sleeping anyway :wink:

I did try yum history undo, but it didn’t work for last nights updates:

[root@srv01 ~]# yum history undo 148
Loaded plugins: fastestmirror
Undoing transaction 148, from Wed May 24 20:30:09 2017
Updated interworx-5.1.51-1304.iworx.noarch @interworx-release-candidate
Obsoleting interworx-5.1.52-1311.iworx.noarch @interworx-release-candidate
Updated interworx-horde-5.2.10-1304.iworx.noarch @interworx-release-candidate
Update 5.2.10-1311.iworx.noarch @interworx-release-candidate
Obsoleted interworx-hotfix-5335-1304-1.noarch @interworx-hotfix
Obsoleted interworx-hotfix-5352-1304-1.noarch @interworx-hotfix
Obsoleted interworx-hotfix-5354-1304-1.noarch @interworx-hotfix
Updated interworx-phpmyadmin- @interworx-release-candidate
Update @interworx-release-candidate
Updated interworx-roundcube-1.1.2-1304.iworx.noarch @interworx-release-candidate
Update 1.1.2-1311.iworx.noarch @interworx-release-candidate
Updated interworx-smarty-2.6.19-1304.iworx.noarch @interworx-release-candidate
Update 2.6.19-1311.iworx.noarch @interworx-release-candidate
Updated interworx-squirrelmail-1.4.23-1304.iworx.noarch @interworx-release-candidate
Update 1.4.23-1311.iworx.noarch @interworx-release-candidate
Updated php-iworx-1:5.6.30-1.rhe7x.iworx.x86_64 @interworx-release-candidate
Update 1:5.6.30-2.rhe7x.iworx.x86_64 @interworx-release-candidate
Loading mirror speeds from cached hostfile

So, you are saying your testservers are on RC and they have updated to 5.1.52-1311 but show no problems? 5 of our servers have this issue and those 5 updated yesterday evening.

yum downgrade interworx did the trick!!

Hi Michael
Phew, many thanks
Sorry power here has been up and down
I thought it maybe anissue on centos 7, so managed to start a test server running centos 7, and updated to latest IW.
All was fine
Sorry I never thought of yum downgrade interworx, too mcuh smarty in mind
I think if you compare your index.tpl, you may find } missing
Many thanks
Ah actually I think I may have found your issue
In your log (“file:/home/interworx/nodeworx/smarty/templates/nsp/index.tpl”), did you create nsp template
I checked on our default Centos 7 IW and we do not have a nsp template
I suspect if you change your template your using, the update may well work, thereby confirming the error is in the nsp template index.tpl
Sorry if I am wrong
Many thanks


Hi John,

our nsp theme is based on Heliotrope and index.tpl is almost identical - at least nothing in there that seems to have caused this:

But anyway, thank you very much for helping, as always you brought me on the right track.

Hi Michael

Many thanks, glad to have helped a little

You may want to do updates as we do, set all production to IW stable, then set the least important IW server to RC (use this as a test server for updates).

It saves a lot of time and gives peace of mind but you manually have to update production servers, which you do at a time that suits you (just remember to change them back to stable)

There does appear to be an issue with smarty though, so I have opened a support ticket with IW. It does not appear to cause any loss of any service, just shows issues

Glad it’s been resolved so you can work though

I’m going out for an hours drive, too many alarms sounding all the time, so giving brain a rest.

Many thanks


Latest update: It has to do with smarty, since only downgrading IW doesn’t help.

In order to fix this I have to run yum history, find last nights hotfix (May 25 01:01:31 Installed: interworx-hotfix-5363-1311-1.noarch ), undo that via yum history undo ### (###being the number in the history list), then downgrade IW via yum downgrade interworx AND downgrade Smarty via yum downgrade interworx-smarty


Are you running a custom theme? If so, there is a known issue from the update where, since we updated Smarty to 3.1, custom themes have been affected. You should be able to resolve this by editing the ~iworx/iworx.ini file to change the theme from your custom to heliotrope for the default NodeWorx and SiteWorx template:


If that doesn’t resolve the issue, submit a ticket and we’ll take a closer look. :slight_smile:

Good morning Jenna, isn’t it like realllllly early over there? :slight_smile:

Anyways, yes, we are running a custom theme, but it#s only a heliotrope with our logo added, nothing else really. I was able to fix the problem by downgrading and I will open a ticket to see if we can solve this permanently.