Problem with SMTP...

Hi I’m having an intermittent problem with one of my accounts mail smtp server.

I’ve restarted the mta agent and the mda agent and even rebooted the server but this one account cannot use the smtp server to send mail.

Don’t see any problems in any of the logs, tried stopping the firewall, all to no avail?

Where do I need to look next?

You might want to go as far as doing a complete deletion of the site off the server and reinstalling it.


Can you give us a few more details about the problem. So, you can receive email on this domain, but you can’t send email from the domain?

Have you tried sending mail from the webmail client, or a different desktop email client? If you can send from webmail, that would mean something is wrong with your email client, or something is wrong with the communication between the server and your email client.


Yes, mail can be sent from webmail, my client first reported it and he is using outlook. When he first reported it I set up a test email account and tried it using Opera and had no problems, making me suspicious of things on his end. He reported earlier this week that the problem had cleard up, but then reported again this morning that the problem had resurfaced. I tried it again using the test email and am having the problem on my end with just this particular domain. All other domains work fine. The mail server is pingable ( receiving mail works just fine also.

I have looked at the mail logs and don’t see anything in the logs I’ve looked at.

As a side note, I deleted the test user from the domain and tried sending an email using the id expecting to get an immediate authentication failure, but it took nearly 15 minutes for the server to respond with the authentication prompt…

That is making me think somewhere there is a problem with authentication, but that’s just a guess…

Is your client’s ISP blocking outbound port 25 connections bluesin? Can he telnet to port 25 on the box and see the standard smtp greeting?


Not sure Chris, but as I’m having the same problem with the test email, I’m fairly certain its not on his end at this time.

As I said, this is the only domain out of the 30 or so that is having a problem, I tried telnet to several of them with “telnet 25” for several of them and I don’t get connected to any of them via that method, however as I said, all of them work except this one when sending mail…

You want me to open a ticket with all the info?

I think we are having the same problem…

I am going to jump in on this one. For approximately two months now, we have been having the same problem. POP3 and IMAP work perfectly, but SMTP connections may or may not work. I thought it was a problem with Mozilla Thunderbird, because everyone in our office uses it and no one else was complaining, but an Apple Mail user reported the problem last Friday. :frowning:

The problem is difficult to reproduce, but it is effortless to cause. You simply…

  • Compose an email
  • Click "Send"
  • 1 out of ~15 emails will block with an error message (attached to this post)
  • Trying again (immediately) will succeed without a problem[/LIST]

    My personal testing found that SMTP w/o TLS almost never produces the error.

    More evidence

    We have written a photography sales system (Mozart Photo System) that sends emails to customers who have requested a reminder before photos are taken offline. I noticed that (rough guess) 10-20% of a store owner’s nightly emails would fail, although the script (called by cron) is only trying to connect to the local SMTP server. (I think that rules out the possibility of faulty data center connection.)

    While trying to make Mozart’s emailer more resilient, I found some interesting properties surrounding the problem. Note that the problem can be reproduced by “hammering” the server, but I’m not talking about “attacking” the server. I just mean a script that needs to send 10+ emails in a row is very likely to surface the bug.

    My test setup was trying to send an email 10 times to the local server and local email address. When the script failed to send an email, the script will enter to a recovery loop that would try 2 more times. Here is what I discovered:

  • Trying 3 times would fail all 3 times.
  • Trying 3 times, and sleeping 10s between each attempt, would fail all 3 times.
  • Trying 3 times, but first establishing a new connection, recovered everytime on the 2nd attempt. NO sleep was required. [/LIST]

    So Mozart’s emailer is now working fine, but the mail server’s strange behavior is very similar to Mozilla Thunderbird’s. Thunderbird would fail once, but try again (make a fresh connection), and the mail would deliver just fine.

    I am fairly sure this problem is very recent (within 3 months). Would an upgrade or downgrade of the mail server, and/or its dependencies be a good idea? It is possible the mail server’s memory limits are being hit?


  • It wasnt until jimp’s message I realized this VERY thing has happened to me a few times. On the first attempt on sending to try to send (using Outlook Express) , I would get some kind of error, and then I retry again right after, and the mail will go through.

    It only happens once or twice a month and I just assumed some internet glitch, BUT since I see that others are having the same problem, I have to say HUMMM


    Is that a screenshot from Thunderbird, Outlook Express, or some other mail client? It may be useful to have a screenshot of each (one from Thunderbird, one from Outlook Express).

    Regardless, to those who are affected, we are looking into the problem. I believe Bluesin has a ticket open right now, and we’re working on diagnosing and consistently reproducing the problem.


    The screen shot is from the latest Thunderbird.

    While I was fixing the Mozart built-in emailer to be more fault tolerant, these are the error messages I could produce consistently. I think the two notices followed the “Failed to set sender” warning everytime.

    Warning: Failed to connect to [SMTP: Invalid response code received from server (code: 421, response: unable to read controls (#4.3.0))] in ${PATH}/${FILE} on line 162

                             Warning: Failed to set sender: ${EMAIL_ADDR} [SMTP: Invalid response code received from server (code: -1, response: )] in [I]${PATH}[/I]/[I]${FILE}[/I] on line 170

    Notice: fwrite(): send of 37 bytes failed with errno=32 Broken pipe in /usr/lib/php/Net/Socket.php on line 294

    Notice: fwrite(): send of 6 bytes failed with errno=32 Broken pipe in /usr/lib/php/Net/Socket.php on line 294
    Also note that Mozart’s emailer uses PEAR_Mail to actually handle the delivery.

    In my case I was using Outlook Express. The next time I have the problem I will post a screen shoot here of the error. However I have not had the problem in a while.

    OK, the SMTP error happened again (good timing). Right after this error message I sent the email again just a few seconds later and it sent successfully.


    Ok, this appears to be a problem with bellsouth blocking port 25 for new domains.

    There is some other notes on it about migration and such, but I suspect that they are allowing older domains to transfer through port 25 and blocking newer ones.

    I set up a new account this week and I cannot use the smtp server on it either.

    Many ISP’s are doing this, i’ve seen references to setting up alternative ports, can someone provide instructions for doing so?


    We’ll have a point release out this week that will allow you to easily setup the alternate port (defaulting to 587). I’d recommend waiting for it but if you need it ASAP we can get you a pre-release version of the software.


    Thanks Chris, no problem on the wait…

    Oh and Chris, do you know if it will be set up to listen on both ports or does it have to be just the alternate?

    It has to work on 25 bluesin or else smtp itself will break :). So the 587 is just an alternate in addition to 25.


    That’s what I thought, thanks Dude!

    Has anyone made any progress on this one?

    OK I dont feel bad asking this, I asked two other network guys what bluesin is and they didnt know.

    Cant you enlighten me?