R1soft plugin does not work with latest version 5.1.29

Hi All,

It looks like the latest version of Interworx (5.1.29) breaks the R1Soft plugin.
This is causing massive headaches for myself and my clients.

Is anyone aware of a workaround or a way to fix the plugin?
Alternatively, is it possible to install older versions of Interworx (I can then disable updates, until the plugin is fixed).

Thanks in advance!

Hi PJFlo

Welcome to IW forums

Many thanks for you post but I can confirm that IW have not broken r1soft script.

I know this because IW and myself have been looking into why all my r1soft siteworx restores are not working

The r1soft is creating the backups as it should

Restore from the r1soft account itself works as expected.

It is only effecting the siteworx account restore user function, where it passes over the correct credentials to r1soft API but r1soft itself is then closing the connection

R1soft are looking into this, but have been for almost 2 months or so and its still ongoing

I have various IW servers, with various IW versions, and all are not working as above

You may want to ask r1soft to contact IW support as r1soft are not forthcoming in contact with IW

I hope that helps

Many thanks


Dang, last week I decided to move over to R1soft and bought a license, and I haven’t seen this… Let’s hope they will resolve it soon.


I’ve reported this issue to iworx support on April… the answer was to contact R1Soft :-o

Sorry guys… moving clients with complains over to cPanel :’(


Hi paulo

I’m sorry to hear that but understand your reasons

Please understand, the issue with R1soft appeared around that time BUT it is important to understand that it is NOT interworx which is failing.

Interworx is correctly passing all required information to R1soft API, and R1soft last week requested a strace of the IW R1soft plugin, which in conjunction with IW and one of our servers, has been fully provided to them.

I have yet to receive a response other then the confirmation of receipt of strace email

This strace clearly shows Iw R1soft plugin been accepted and authorised by R1soft API, for the correct siteworx account, and clearly shows the plugin after passing authentication, in a waiting state for commands from R1soft API, but R1soft server API is then closing the API connection in full and a Iw cleanup takes place

I hope you and everyone can appreciate the frustration of Iw to this issue, which is outside of Iw control

If anyone wishes to have a copy of the strace, please let me know

Many thanks



Sorry I meant to also state

R1soft backups are been made correctly and held on the R1soft backup servers

Access/restore for siteworx:servers can be correctly completed by logging into your R1soft admin account with your R1soft provider

The issue of restore failure is only present when a siteworx user tries to use the R1soft restore plugin

Many thanks


Hi Jonh,

I do understand but our clients doesn’t because the service is “down” for them :frowning: and before they move to another provider, we had to setup new servers with competitor panel …



I thought I would update this thread with the latest development, which this issue has now been passed to the Devs at R1Soft
Hopefully,should not be long long, but I am dissapointed that it took a long time to reach this point, after many debug tests/logs having to be undertaken/sent to prove where the issue is (I did give full access to one of our servers, including root access)
I will update this thread further as I receive information
Many thanks
Hello John,
Your ticket was escalated to development team. This is the last update:
I have escalate this case to our development team to investigate the issue further.
Hence I will request you to please standby till further update.

Excellent news, Nathan, IW Team and R1soft Devs are making progress, and hopefully a hot patch will be pushed very soon.
Our R1soft access is now restroed, and works lovely, and we upgraded to latest R1Soft after downgrading to V5.10 to make sure it was not a version mismatch.
I hope that helps, and Kudos to IW, they rock
Many thanks

John, I’m using R1soft now, but not exactly sure how the plugin works?

Does the normal backup of the root / which has the /home directory automatically link up to the SiteWorx account? Or is it just so that iworx backups can be stored on an R1soft server?
I’ve been googling around but have yet to find anything useful.


Hi justec

I hope your well

Once the plugin is active, and a full backup has been completed, each siteworx account can access their own backup and restore or download, including any databases

There is a misconception though when restoring, in that if doing a full restore, if you do not delete the current /home or root hosting folder etc… R1soft will just overwrite and not delete then restore. This is important to know, because if the site has been hacked or foreign files added, and you just restore, these files will still exist

All the files on the server are backed up, so you could do a bare metal restore, and the way the siteworx account is handled, is when clicking the R1soft backup, the plugin passes the siteworx Unix name and password (encrypted), which is then used to only show the siteworx account backup only (everything from the /home/siteworx/)

The above issue which has now been resolved, was failing after the correct siteworx credentials were passed and accepted by R1soft API but the API closed the connection. You could still access the backups by using your admin account

I hope I have explained a little, but if you want, I could post some pics tommorow from a test account

Many thanks


Thanks, things are good, hoping everything is good for you as well.

So this is what I thought, I just wasn’t sure how it worked, but now I get it. I am already doing a full backup of the / mount so I could do a bare metal if needed. So basically once the plugin issues are resolved, then just from that same full backup, they will be able to restore files themselves. That’s pretty cool. No separate backup needed so you save backup storage space.

Does this require that you do the MySQL plugin SQL backup as well? Or is it able to pull backups of database from the /var/lib/mysql directory?

Because I’m thinking if I do the full / backup, that will have the actual filesystem MySQL database files. So if I also do the MySQL backup, my backup will become bigger, basically backing up the size of all the databases twice. Maybe this isn’t the case, I’m not sure. Maybe it is the case, but it’s just better to have both the MySQL file and the MySQL actual SQL backup.

Thanks for making this more clear for me.

Hi justec

Many thanks, and I’m well, it’s very cold here though 1 degrees

The MySQL is only back up once, all files

The plugin for MySQL, which runs under mysql root, makes it simple for siteworx users to restore the database

The simplest way to explain is to say the MySQL R1soft plugin, is like you manually typing the commands to restore a database but without the manual effort

I hope that helps and sorry for not exposing too well

Many thanks and have a lovely night


HI Justec
I thought I would post some pics to show how it works from a siteworx user experience.
All the restore points seen in the pics are real, details blanked for domain etc, and all restore data is taken from the full backup made of the server, but as a siteworx user, only the siteworx backup is shown.
I hope that helps a little to others, and this also shows the R1soft restore access now working as at todays date. Kudos to IW and R1soft devs for finally resolving this issue, which was very invovled.
Many thanks

I can I understand that from the R1soft Plugin side, but from just a general R1 Soft side. Am I right in thinking that your backup storage space is double for database?

File System:
With example files:

MySQL Plugin
Direct dump of these tables

The backup space is pretty expensive with the hosted R1solutions, so just trying to figure out the best way to manage it.

Hi justec

I’m not 100% sure

The download of a database, has the opt, frm, myd and myi files, so I’m thinking there is no dump made

Thinking though, if your using R1soft already, have you disabled the Iw backups and deleted all of these backups, as there not needed

I’ll check my R1soft logs to see if a dump happens, but I think it’s a live snapshot of the folder

Many thanks


The latest release candidate update, now includes the R1soft fix, and I can confirm it works lovely for me.
@Justec, I had a look for a MySQL dump, but I cannot see any on the R1soft backup servers, so I do not believe a dump is made. I think it is hot copy of the databases.
Many thanks

We can also confirm this is all working again.

Combined with the new R1Soft UI, things are looking good.

Would be great for the plugin to allow us to define more than one disk safe for the clients to have access to though.


Sent from my iPhone using Tapatalk

Hi hacman

We use R1soft on a number of different Iw servers, and there on different disk safes in different countries. (We do not use our own R1soft servers)

I think this is achieved by the url and license code, but not running our own R1soft servers, I cannot be sure

Is there any identifiable detail on a R1soft server to give correct disk safe, or is this setup in the R1soft server directly, and your thinking of API integration

Many thanks


I just wanted to test siteworx restores and am getting this error:

Warning! You are attempting to use an invalid control panel ID to login. ALL LOGIN ATTEMPTS WILL FAIL. If you think you are seeing these messages in error, please contact your Backup Manager administrator.

Is this the same error you guys had or is this something else?

Backups work, accessing the siteworx recovery points from the SBM panel works too. The Agent Version is, the manager version too (6.2.2 build 78).