reinstalling problems

I deleted for error some file from /usr/local/interworx/var/lib/ y tried to reinstall the panel with…

sh -u -k

but the system is not fixed.

how can i reinstall the system?

Can you please give a few more details about what you did? What did you delete from /usr/local/interworx/var/lib? What commands did you run when trying to reinstall the system?

And also, out of curiosity, what caused you to delete files out of /usr/local/interworx/var/lib? :slight_smile:

i was coping some files to mysql (other databases). a bad moving fillthe lib dir with mysql files. i thought that was the same files and i deleted them with rm

now i tried to uninstall with ‘yum remove interworx’ and i tried to reinstall with ‘sh -u -k’

the problem persist

i used putty but now i’m using WinSCP to do this things…

yum remove interworx

will remove the interworx, interworx-siteworx, and interworx-nodeworx rpm’s but it does not remove everything that the instll script installs and it won’t necessarily leave a system that is ready for the iworx reinstall.

rpm -qa | grep iworx

will list all (well most) of the Iworx related RPM’s that are still on your system.

I think I see your problem, though.

You reran the install script, but I take it you didn’t reinstall the database?

[I]cd /home/interworx/bin


NOTE: This will destroy your old InterWorx database and all of it’s settings and data if it still exists but it sounds like you destroyed it already so it may be safe.

I’m not an InterWorx developer so to be safe I’d waith for Socheat’s next post to see what to do next. He once told me to NEVER EVER rerun goiworx.pex but this MAY be the exceoption to that rule

i must to uninstall ALL programs?? apache, mysql ALL? Is this usualin linux?

I’m paying a dedicated hosting… my site is down… i’m losting money

please what i must to do to solve the problems?

It’s rather complecated, interworx installs it’s own versions of many programs (packages) and yum erase interworx only removes the three I listed. I am not telling you to remove the others. I wasjust illustrating that the command you used does not remove everything.

I suspect thta the second part of my post about goiwrx.pex is related to your problem but DON’T do that without hearing from Socheat or sone of the others.

Since your problem is urgent:

Did you buy your iworx licence from your data center? If so, you can open a support ticket with them. If you bought it here on this site you can put in a ticket here and they can fix it for you, but you will probably have to pay the $49 reinstall fee.


Removing your InterWorx RPMS has effectively killed all the InterWorx meta-data about your SiteWorx accounts, etc. Unless you made a backup of everything in /home/interworx a reinstall of your OS is very likely the best and cheapest solution at this point.


there isnt an option to re-install without delete allthings? is that posible? i must to delete all and start again for a stupid tiny error?

‘yum remove interworx’

does not equal

‘stupid tiny error?’

They are right, you should start over.


An expensive lesson I know – having learned it myself – but with Linux there really isn’t sucha tthing as a “tiny error” especially when you are logged in as root.

It is possible to recover without a fill OS reinstall but it could be quite messy as well, the best solution is probably an OS reinstall. What I suggested I have never done on a live server, I did do it once on a VPS test bos to see if it worked and it did but it was a mess, if downtime is costing you money it is probably cheapter to pay the reinstall fee.

intried to uninstall all. now dont run the install program… everbody talking about windows sucks linux rulez but this not occurs…

the money only pay the hosting…

you are telling me that there isnt any way to restore the panel if i delete 5 files??

The databases you deleted were the core databases that InterWorx uses to operate. What you did was like deleting the entire Windows Registry. How easily can you completely recover from that, back to the original state of the system, without a backup? In both cases, InterWorx and Windows, it can be done, but time consuming and probably best to just reinstall. I know that’s not what you want to hear, but it’s the truth.

i doesnt deleted the mysql databases i deleted the files from lib directory. but no mysql directory, mysql info was intact.

now i uninstalled lots of things (as people tell me) to try to install again but now that files YES are deleted (NOT after)…

I execute the install and it tell me this…

TARGET : Red Hat Linux release 9 (Shrike)
RPM DIR : /usr/src/redhat/RPMS
SRPM DIR : /usr/src/redhat/SRPMS
Press <enter> to begin the install…
STATUS: Importing RPM GPG keys
error: import read failed.
error: import read failed.
error: import read failed.
error: import read failed.
error: import read failed.
STATUS: Setting up JAILED home/chroot dirs
STATUS: Looks like jailing is already setup
STATUS: Checking for YUM
STATUS: Installing YUM config file & updating YUM
IOError - # socket error - (-3, ‘Temporary failure in name resolution’)
STATUS: Upgrading CURL for RedHat 9
IOError - # socket error - (-3, ‘Temporary failure in name resolution’)
STATUS: Upgrading libcurl3 for RedHat 9
IOError - # socket error - (-3, ‘Temporary failure in name resolution’)
STATUS: Installing MySQL server
IOError - # socket error - (-3, ‘Temporary failure in name resolution’)
ERROR: MySQL could not be installed.

No one is saying it’s not possible, but it is very hard to do and having done several InterWorx installs and had some botched ones from my DC I can tell you that if things aren’t done completely corectly you will have problems later. The cleanest and best way to fix this problem is a reinstall from your DC.

Linux does not have an “undo” button or recycle bin, when data is destroyed it is gone forever unless you have backups.

The files you deleted can not just be copied off the Windows CD or the InterWorx RPM’s, they are generated during the Iworx RPM and license installation similar to the Windows registry as Socheat mentioned. Even with the complicated procedure I mentioned you would still loose alll of your data (it’s already gone) and your install mightnot be completel “right.”


Unsleep, what are the contents of your /etc/resolv.conf?

Can you enter the directory


and type the command

ls -la *

and spit the contents out here? I want to see the sizes of the files in qestion.

now after unstalling all programs, nothing

but now i installed some interworx things changing the domain to the real ip but other things do not run with the same trick

i installed bind because dns doesnt resolve…

cat /etc/resolv.conf

the problem now is names are not resolved… i tried to install bind but the problem persist

It’s clear that you haven’t reinstalled the operating system. The best thing to
do is to reinstall your operating system, and proceed from there - otherwise
you’re going to run into all these problems that you keep running into, and
you’re just going to get more frustrated.

I assume you’ve uninstalled tinydns, which is why there was no DNS server
available. And you can’t install InterWorx with BIND installed, since the
InterWorx installer will install TinyDNS.

If you continue down this path, you’re going keep running into roadblock after
roadblock, and by the time you finish, you’ll have spent much more time than if
you had reinstalled in the first place.