Squirrelmail folders not listed, can't create folders, 1 user only, other clients ok

Instead of a folder list, a user is experiencing the following error in Squirrelmail:

[INDENT]ERROR: Could not complete request.
Query: CREATE “INBOX.Learn Spam”
Reason Given: Cannot create this folder.

The [Siteworx] user’s postmaster account plus a test account behave normally. Roundcube and IMP likewise work fine for the same user. All other domains are normal. Just this one mail account has the problem.

In shell I verified the user’s ownership and permissions are ok. And as stated, maildir folders and files are intact.

Years ago when I encountered a similar error in Squirrelmail it turned out to be a typo for the IMAP namespace in the config file but that’s not the problem this time.

Only other oddity is that the user’s spam folder had collected over 16,000 messages so I deleted them. Courier has no problem with thousands of messages, but perhaps it caused Squirrelmail to choke?

Suggestions on where else to look would be appreciated.

Hi sysnop

Please could I ask what version squirrel mail your on and does any other email account portray the same issue

It’ll be tommorow before I can check but the reason why I asked for the version, is I remember squirrel mail has an update in the last release of IW updates I believe.

Many thanks


Hi sysnop

I’m so sorry, I just checked and it’s horde I’m thinking about for a small update sorry.

A thought though, has the user enough space free

Also, I could be wrong but I believe myself when SA has completed it’s run on the training of spam email, you might be alright deleting the spam email, which if set correctly, should receive an email from SA informing you of basian learning complete.

Have you tried to delete some from spam and seeing if it then works as expected.

I hope that helps a little

Many thanks


Plenty of disk and I also allocated more memory to POP/IMAP. Both the spam and trash folders were emptied but no results. Also cleared out /tmp and stopped/started services involved. IMAP folders display fine in Roundcube and Horde for the problem account, and no other accounts/domains exhibit the problem.

It’s definitely a Squirrelmail issue (version 1.4.22). My research isn’t revealing many straight answers to this type of error no matter the environment or control panel packages. The errors have been reported with every MTA/MDA out there and it didn’t matter if the storage format was maildir or mbox. That’s about all I got for clues. It’s a puzzle more than setback since the user’s mail is moving fine in Roundcube. I’ll chug along and post anything new if I find something.

Hi sysnop

Many thanks, and I know it’s frustrating when this happens.

It’s a mute point, and one I’m sure you have tried sorry, but have you tried recreating a new config for the user.

Thanks for confirming it is specific to 1 user and happens with all different installs, you saved me testing, thanks.

I hope that helps a little and once again, I’m sorry as I’m sure you have tried the above already.


I ended up backing up, deleting and restoring the account and it all seems back to normal. Turns out there were issues with Roundcube also (didn’t try IMP). Beforehand I re-checked owner/permissions in the user’s Maildir directory and everything matched up like a working account. I attribute the problem to a corrupted file somewhere, or a quota problem despite the user’s mail quota equaling total storage for the Siteworx account. I’ll never know for certain.

All is well. Thanks for your input John.

The problem has returned. Same errors, same mail user.

Squirrelmail error has replaced the folder view:
[INDENT]ERROR: Could not complete request.
Query: CREATE “INBOX.Learn Spam”
Reason Given: Cannot create this folder.


Able to use Roundcube but undetected spams have clobbered the inbox. In fact, spam volume is enormous for this particular user. When I try to drag/drop spam to the Learn Spam folders Roundcube gives this error:
[INDENT]Connection to storage server failed.

As I described the first time – quotas and permissions match working accounts but I’m only checking ownership and permissions for the user’s Maildir directory and contents.

The user is quite upset, to say the least, but this problem is beyond my pay grade. Suggestions?

Hi sysnop

I’m sorry to hear it’s come back.

I read your post about an hour ago and was thinking about possible courses of it.

I know it seems going over things, but could I ask

Does the siteworx account have enough space
Does the reseller have enough space

I’m thinking the email user has enough space allocated, hence asking the above

Is you /home folder on its own seperate nas or storage device, or part of the IW server

Are you on a cluster, and if so, is there any logs to show which node maybe giving the error

There’s a few suggestions you may like to try, but it will be frustrating for the user as it applies to only their email account as follows, but use at your own risk

If you use 1 click installer on domain, to install latest version of roundcube (note do not upgrade roundcube or you’ll break all your roundcube for all domains) - this should give you access to the user email and see how that works

Can you backup and delete the user email account, and setup a new email account, but do not import the backup, to see if this corrects the issue

If you want, you can access our test server, create your siteworx account, and set use for email to see if it duplicates the issue, or if you have another IW server to do same test on

I myself are inclined to think it is likely to be a space issue, given roundcube error, or a connection issue to your storage device but I’m sorry, I do not know your setup.

I hope that helps a little, and sorry if I’m wrong but also, you may want to open a support ticket.

Many thanks


Hi John,

Space and allocation are ok for the Siteworx account (30% used) and the problem email account is set to unlimited. I’ll try a solid but generous number for the mail quota just in case ‘unlimited’ is a problem. The main Nodeworx user is the only reseller and space isn’t an issue. The user’s /home directory is the same partition as everything else and I’m not on a cluster.

Your idea below occurred to me also and it’s my next step:

I also considered a fresh account with a different name, and use the old account name for an alias.

I overstated how upset the user is; he’s annoyed but has been a good sport about it as long as he’s able to send/receive. I think the account is so over-spammed he could use a different email address at this point.

Thanks for your response and I’ll come back to this thread with my results… may take a day or two.


Hi Richard

I hope you don’t mind, but a post from this morning made me think it might apply to this issue.

Do you use quotas and limits, this would be os I’m talking about, and if so, is there space available.

It’s just a thought and may not apply to you sorry

Many thanks


Good morning John.

If you mean user & group quotas compiled into the kernel, then no – I haven’t done anything like that. I bought a bare VM with a preset CentOS image, then I installed Interworx assuming disk quotas were being taken care of. In the past I have had quota issues with iworx (and other CPs) that required recompiling them into the kernel (the name for this escapes me). But the problem was revealed by empty or incorrect quotas in Nodeworx. I see no such discrepancies in Nodeworx and allocated space is reported correctly. Am I on track with that? I’m a Linux noob and would need a refresher course if I’m overlooking anything.

Hi Richard

Many thanks, an I was referring to that precisely, Virtuoza I think from memoy.

It was just a thought, an worth asking but as your on centos, it would not apply, it might if you were on Cloud Linux.

Hope that’s alright

Many thanks


Yeah, that’s what it was – either a Virtuozzo or OpenVZ VPS that needed quotas compiled. The one I’m on now is KVM.

So far the mail user’s re-created account seems stable except for his spam volume and lots not being flagged into the spam folder. I hadn’t run sa-update in quite a while but did today. Keeping a watchful eye before restoring messages.

The problem is back. Same symptoms. Backed up messages had not been restored and the inbox contains very few messages, so I think I can eliminate corrupt or rogue messages. It’s interesting that it took roughly the same amount of time as last time before breaking: about 48 hours after re-creating the account from scratch.

Bayes learning folders are suspect since 1) the Squirrelmail error refers to a learning folder; and 2) Roundcube produces its storage error when trying to drag spam to the Learn Spam folders. And as I describe before, there has been a lot of undetected spam in the user’s inbox. I’m wondering about cron at this point considering the timing, plus sa-ham & sa-spam rely on daily cron jobs, am I right?

I’ll check logs to see if there’s anything revealing. Meanwhile, I’m going to suggest to the user to stop using the account and try a new one.

Sorry to report it’s not resolved.

Hi Richard

Oh dear… I’m sorry it’s still an issue but as you say, it helps in narrowing the issue, ie old store not corrupt.

I myself am still inclined to think it is connected with space, or permissions, as both errors states failure to create if I’m understanding correctly.

As space is not an issue, has the user correct permission to create a folder, and or does iWorx have rights to do this.

I’ll have a think further but it is a strange one, particularly when you consider it only happens to 1 user on domain, which I take it there are other users on same domain.

I hope that alright

Many thanks


Hi Richard

I hope you don’t mind, but a thought has come to me as follows

When logged into the users email account as the user, can you delete the folder and then create the folder

It’s just a thought, based on permission and if I have time, I’ll try this on a test account, as I’m not even sure if you can do this from the account.

Also, when you created the account new, was SA basian processing the junk mail, and did you receive email confirming it had been added to spam.

Many thanks



I nixed the entire Siteworx account for now. First question: Can you think of house keeping I need to do before re-creating the account?

Something occurred to me about this user’s account and I’m willing to bet it’s pertinent regarding permissions and/or disk quotas:

Prior to starting this VPS only a couple months ago, I was using a VPS from a different provider, also managed with Interworx. The OLD virtualization software was OpenVZ on CentOS 32-bit. The NEW and current server is a KVM virtual machine on CentOS 64-bit. After installing Interworx I manually created my own Siteworx accounts from scratch. The problem user’s Siteworx account, however, was imported from the old server. It all seemed to have gone smoothly until this issue began a few days ago. I think we may be onto something regarding how the two types of virtualization environments handle disk quotas and/or permissions.

I’m about to re-create the user’s Siteworx account. But since he has a Wordpress site and a database, I’m not sure if I should manually create the site and import the site and database from today’s backup, or do it manually. Importing a FULL backup normally creates the user name and other account info, right? Therefore, I am inclined to create the Siteworx account manually and name the user differently this time to ensure the cleanest slate possible.

I will report back with my results. Meanwhile, suggestions are welcome although I’ll probably have started the restore within the next couple hours.

Thanks for sticking this out with me.


Edit: I do have partial backups of the database and site only in addition to a full backup.

Hi Richard

Good point, and I’m thinking it might be as you say, but as I know, quotas changes needed for vps are so they can access quotas. as set by IW-cp.

I’m thinking somewhere along the line, it might be a difference between 32 and 64 bit, but it’s hard to say, and could be a mixture between them both.

I’d be tempted to install on a full server, see how that works and then do an IW to IW import.

I’m also thinking if you perhaps run a quotas check before doing anything, just in case there’s a mismatch in quotas. If you look up mikei post, you’ll find the link to check for vps.

If you want to use our test server, pm me and I’ll give you full access, so you can test, create as you need, but it’s running php 5.6 and has a few mods in place.

I do honestly believe though, the error is as it states, cannot create, the reasons why can vary, but is likely to be quotas.

I hope that helps a little, and your welcome anytime, I’ve always time for people like you, and I’m sure it will get resolved.

Have a lovely weekend

Many thanks


Not only has the problem resurfaced, it’s happening to a second domain now. Can I enable remote support and submit a ticket?

Hi Richard

I would think you would need to open a support ticket with your IW licence provider, unless it was IW direct, but sorry if I am wrong.

You may want to ask IW support, but please do not feel upset if they first refer you back to your IW licence provider, which if the licence provider cannot resolve, they will open a ticket with IW.

I’ll pm you anyway, if you don’t mind, but I am nearly positive now that it has happened with another account, it is connected with quotas (group and user), which I think it is not reaching the quota. file of IW.

Have you tried these commands, and do they look alright, the first shows you your quotas, the second repairs the quotas, and the third is the link to the post re quotas.

If repairing, please allow 5 - 10 Minutes to elapse for quota recheck of file system run, to detect new quotas.

I hope that helps, and sorry if I am wrong.

Many thanks


Check Quotas

repquota -avug

Repair Quotas (please note, / refers to the Quota found in iworx.ini, under “quota”, which if default is / )

quotacheck -cugvmf -F vfsv0 /

Post re Quota